kppw2.2众包威客开源系统破解版安装教程

安装教程

1、kppw要求的php版本为5.6,一般新服务器安装phpstudy,选择php5.6版本,会提示缺少运行库。这里提供v9和v11下载,如果还缺其它运行库,请自行百度下载。phpstdy安装包、运行库以及多版本共存需要的包,KPPW客客出品专业威客系统 v2.2 UTF8 破解版

2、下载phpstudy安装包后,直接解压安装。我安装在D盘了->D:\phpstudy,安装成功后,启动如图所示

 

3、kppw要求php版本5.6,现在点击切换版本,我一般选择apache+php的组合,如图所示
《kppw2.2众包威客开源系统破解版安装教程》

一般这时候如果你缺运行库,它会提示你的。按照要求,下载相应的运行库安装即可

4、新建站点,如图所示,
《kppw2.2众包威客开源系统破解版安装教程》

《kppw2.2众包威客开源系统破解版安装教程》
5如上图所示、我配置的域名是www.kppw.io
网站目录D:\phpstudy\WWW\kppw.io
第二域名 kppw.io
网站端口 80
然后点击设置并生成配置文件。
《kppw2.2众包威客开源系统破解版安装教程》
6、如图所示找到配置文件,找到配置文件后还需要做一些修改

《kppw2.2众包威客开源系统破解版安装教程》

7.这些弄完后还需要开启一些扩展
《kppw2.2众包威客开源系统破解版安装教程》

8、以上操作弄完后,点击重启,(每次修改配置文件都是需要重启才能生效的),如果两个灯都是绿灯代表启动成功
《kppw2.2众包威客开源系统破解版安装教程》

9、然后网址输入域名https://www.qiyuwg.com就能正常访问kppw安装界面了(请确保你的域名已经解析到该服务器,用ip访问是可以的)

10、如果您是本地安装,那则还需要修改本地的hosts文件,找到C:\Windows\System32\drivers\etc目录下的hosts文件
《kppw2.2众包威客开源系统破解版安装教程》《kppw2.2众包威客开源系统破解版安装教程》

11、服务器安装和本地安装就这样了,有的客户服务器运行有其它网站,但网站使用的php版本和kppw不同。如果再去购买服务器就显得有些浪费了。但我经过几小时的度娘,终于找到解决办法了。那就是php多版本共存了。这个是网上找到的帖子,https://www.qiyuwg.com。下面就是具体的配置方法了
12、把下载的mod_fcgid-2.3.6-win32-x86.zip解压,会得到mod_fcgid.so。找到apache的module目录,我的phpstudy安装在D盘,所以我的路径为D:\phpstudy\Apache\modules,把mod_fcgid.so复制粘贴到modules目录,不管原来有没有直接覆盖掉。
《kppw2.2众包威客开源系统破解版安装教程》

13、找到apache的http.conf文件,如图所示(修改前请备份该文件)

快速查找一下,如果有类似代码,在前面加#注释掉
《kppw2.2众包威客开源系统破解版安装教程》

14、然后在http.conf末尾加入这些代码

#加载fcgid扩展模块(额外说明,fcgid根据实际apache版本对应,apache2版本测试2.3.6正常)
LoadModule fcgid_module modules/mod_fcgid.so
#添加映射
AddHandler fcgid-script .fcgi .php
# 设置PHP_FCGI_MAX_REQUESTS大于或等于FcgidMaxRequestsPerProcess,防止php-cgi进程在处理完所有请求前退出
FcgidInitialEnv PHP_FCGI_MAX_REQUESTS 1000
#php-cgi每个进程的最大请求数
FcgidMaxRequestsPerProcess 1000
#php-cgi最大的进程数
FcgidMaxProcesses 3
#最大执行时间
FcgidIOTimeout 120
FcgidIdleTimeout 120
AddType application/x-httpd-php .php
#——这里是默认虚拟主机配置
#php.ini的存放目录
FcgidInitialEnv PHPRC “D:/phpstudy/php/php-5.6.27-nts”
#php-cgi的路径
FcgidWrapper “D:/phpstudy/php/php-5.6.27-nts/php-cgi.exe” .php

15、点击重启,看apache是否能成功启动(启动失败,就用备份的http.conf文件。再启动看是否失败)

16、比如说现在有两个网站一个用的是php-5.6.27-nts版本,一个用的是php-5.4.45-nts版本。如图所示打开配置文件

然后做如下修改
《kppw2.2众包威客开源系统破解版安装教程》
加入
FcgidInitialEnv PHPRC “D:/phpstudy/php/php-5.6.27-nts” //这代表php版本目录
FcgidWrapper “D:/phpstudy/php/php-5.6.27-nts/php-cgi.exe” .php  //这代表相应php版本的启动快捷方式
我自己的php版本库目录如图,请大家按照自己的实际目录为准进行相应的配置
《kppw2.2众包威客开源系统破解版安装教程》

17以上操作完成后,多版本就配置完毕了。友情提示,配置多版本后,请每次增加站点时,都要指定php版本。还有不要点击如图所示的按钮
《kppw2.2众包威客开源系统破解版安装教程》
如果你点击了,恭喜你。你又需要给你的每个站点重新指定PHP版本了

点赞

发表评论